Firefox sound is choppy (Win 10)

Issues when playing live broadcasts with Unreal HTML5 MSE player on a web page

Firefox sound is choppy (Win 10)

Postby paziCB » Tue Jan 09, 2018 4:53 am

Hello,
when I run live streming so everything works right in Chrome, IE, Edge. In Firefox version 57.04, the video works well, but the sound is choppy.
How to solve this problem?

Thank you for answer
paziCB
 
Posts: 0
Joined: Mon Jan 08, 2018 12:02 pm

Re: Firefox sound is choppy (Win 10)

Postby admin » Tue Jan 09, 2018 9:44 am

Hello,

Is that a live stream, or file added to "live playlist" broadcast?
What are exact audio AAC encoding parameters?; if you can provide a link to a stream, would be nice.
admin
Site Admin
 
Posts: 926
Joined: Fri Aug 21, 2009 10:13 am

Re: Firefox sound is choppy (Win 10)

Postby paziCB » Tue Jan 09, 2018 12:26 pm

Hello,
I'm using live streaming and OBS Studio. The audio problem in Firefox occurs for sound bitrate: 64, 96, 128, and so on.
paziCB
 
Posts: 0
Joined: Mon Jan 08, 2018 12:02 pm

Re: Firefox sound is choppy (Win 10)

Postby admin » Tue Jan 09, 2018 2:22 pm

Yes, I was able to reproduce it too, with OBS encoding at 44.1 kHz; however, it's OK at 48 kHz.
So change the sample rate in OBS settings to 48 kHz. Not sure who's bug it is - OBS or Firefox;
Unreal Media Server simply streams whatever OBS encoded.
admin
Site Admin
 
Posts: 926
Joined: Fri Aug 21, 2009 10:13 am


Return to Playing with HTML5 MSE Player

Who is online

Users browsing this forum: No registered users and 1 guest

cron