Dynamic Connection eLecture

Issues with eLecture

Dynamic Connection eLecture

Postby Johnblack » Tue Apr 09, 2013 3:30 pm

Further to my previous message. I have been able to aliasing on Media Server the dynamic lecture defined by the eLecture Server and I now I can connect through port 5130 my local Media Source to the Media Server for that particular alias. I see on Media Server the alias on the top screen and on the botton screen the address of my router linked to the alias. Activity status:idle. On my local UliveSrcConfig (active connections) I see the IP address of the Media server and the number of the live source connected.Fine. I use the web version of eLecture. I can nvoke as usual the eLecture Web Server residing on the same server where the Media Server is located but then if I try so start the dynamic lecture which I see among the many lectures displayed I get this error message "Alias of the live source is not recognized by the Media Server". Where shall I define this alias ? The live source on my PC is number 01 and its name Home: apparently this information is not transferred to the media Server. How can I solve the problem ?
Johnblack
 
Posts: 0
Joined: Mon Apr 08, 2013 1:15 pm

Re: Dynamic Connection eLecture

Postby admin » Tue Apr 09, 2013 4:40 pm

Well, you know the alias, it starts with "electure_", you are using it with the Live Config program to connect and it succeeds!

It succeeds, so this is a proof that the Media Server has this alias configured. So if you try to play this alias, it can not give you "Alias of the live source is not recognized by the Media Server".

You are probably running some other lecture by mistake.

To start from scratch, do the following:
1. Open eLecture Administration, and delete all live feeds associated with your lecture. Save changes.
2. Add a dynamic live broadcast with the same eLecture Administration program. Now you have a single video feed associated with your lecture. Save changes.
3. With your remote Live Config, use the alias and the password that you see in eLecture Administration program (the alias starts with "electure_") to connect to Media Server.
4. If connection succeeds, you are done!
5. Open up webelecture web interface and start the lecture.

Note that you do NOT need to open up Media Server Configurator to achieve all that.
admin
Site Admin
 
Posts: 935
Joined: Fri Aug 21, 2009 10:13 am

Re: Dynamic Connection eLecture

Postby Johnblack » Wed Apr 10, 2013 2:24 am

Thank you for your explanation. But still I have problems (which never occur in other cases). The architecture of my system is a bit complex. My PC (used for lecturing) is behind two routers: one for WAN (Internet) which has only cable connections and a second for Wi Fi LAN (used by my PC) connected by cable to the WAN router. The systems works perfectly if I have the servers on a fixed IP opening port 5120 toward my PC for the connections. With dynamic IP nothing works. Still I have port 5120 open (but I understand that it is not important in this case) and on the server side port 5130 (and the firewall) is open as proved by the established connection with the Media Server. I suspect that a problem with port forwarding (5130 on the PC side ?) occurs.
Just another question. My Media Server version is 9.5 (sent with the last release of eLecture - tailored for this application ?) and I got a message that version 10.0 is available. I downloaded the version from Unreal site and installed but it is only for 5 connections so I went back to version 9.5. Do I need another license (but I am pretty happy with version 9.5).
Johnblack
 
Posts: 0
Joined: Mon Apr 08, 2013 1:15 pm

Re: Dynamic Connection eLecture

Postby Johnblack » Wed Apr 10, 2013 2:42 am

Further to my last reply. Obviously Dynamic Lecture is unable to take case of possible changes of the IP address on the lecture side (which occurs somehow frequently with an ADSL without fiexd IP) : correct ? Regards
Johnblack
 
Posts: 0
Joined: Mon Apr 08, 2013 1:15 pm

Re: Dynamic Connection eLecture

Postby admin » Wed Apr 10, 2013 9:09 am

I don't see a reason why "With dynamic IP nothing works", and you are not providing any details what does not work.

You are able to esatablish a connection from Live Config to Media Server, so port 5130 is forwarded correctly. So what does not work?

Also,
1. You don't need version 10.0
2. Yes, if IP of your Live Server computer changes, the connection will be closed and webelecture players will stop playing. But Live Server will reconnect automatically,
so people will need to press stop and play on their players or just refresh web page.
Of course, this is not a good thing that IP of encoding computer changes in the middle of a lecture.
admin
Site Admin
 
Posts: 935
Joined: Fri Aug 21, 2009 10:13 am

Re: Dynamic Connection eLecture

Postby Johnblack » Wed Apr 10, 2013 10:01 am

I'm afraid the answer is the same. Once the connection is established (as I explained in detail in m previous messages), when I try to start the dynamic lecture from my PC the message I get is "Alias of the live source is not recognized by the Media Server". So what ? No problems with ports setting in my double router ? What other information can I provide you with to solve this mystery?
Johnblack
 
Posts: 0
Joined: Mon Apr 08, 2013 1:15 pm

Re: Dynamic Connection eLecture

Postby Johnblack » Wed Apr 10, 2013 11:18 am

I have uninstalled all programs and reinstalled. Now it works. Why, I cannot understand. Anyway, all is well which ends well........ Best regards
Johnblack
 
Posts: 0
Joined: Mon Apr 08, 2013 1:15 pm


Return to Experience

Who is online

Users browsing this forum: No registered users and 1 guest

cron