HLS Streaming Seems Unstable by Apache

Supported devices, issues and experience

HLS Streaming Seems Unstable by Apache

Postby terence » Thu Mar 24, 2016 3:46 am

I am using Unreal Media Server V11, Unreal Live Server V9.5
My Windows is Windows 7 Professional 64-bit.
My computer also installed Apache 2.4 as web server for HLS streaming purpose.
My computer also installed SoftPerfect RAM Disk so as to store HLS files on RAM disk.

Now I want to describe the problem, when streaming by HLS, the mobile cannot view the video smoothly. It always does not respond after some minutes. I need to restart the Apache to make the streaming available. The problem becomes more frequently when more users view video by HLS at the same time. Yet, the HLS files are keeping created (duration of .ts file in seconds is 5 and number of .ts files to keep is 10).

So how to make it more stable?
Looking forward to your help.
Thanks a lot.
Posts: 0
Joined: Thu Aug 25, 2011 10:07 pm

Re: HLS Streaming Seems Unstable by Apache

Postby admin » Thu Mar 24, 2016 7:47 am

From our FAQ page:

Also, you must set immediate expiration on your web folder. For IIS web server, open IIS Manager, select your web folder -> HTTP Response Headers -> Set Common Headers -> Expire Web Content Immediately.

Your web server needs to append "Expires" and "Cache-Control" headers to the responses serving HLS chunks, and specify immediate expiration.
http://bertanguven.com/disable-caching- ... -in-apache

And also, why to use Apache if you already have IIS on your Windows box? IIS is, of course, much better optimized for Windows OS than any other web server.
Site Admin
Posts: 926
Joined: Fri Aug 21, 2009 10:13 am

Re: HLS Streaming Seems Unstable by Apache

Postby terence » Fri Oct 27, 2017 6:49 pm

I found that if I configured the apache as the following, it can run smoothly:

<IfModule mpm_winnt_module>
ThreadsPerChild 500
MaxRequestsPerChild 0
<filesMatch "\.(html|htm|js|css|m3u8|ts)$">
FileETag None
<ifModule mod_headers.c>
Header unset ETag
Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate"
Header set Pragma "no-cache"
Header set Expires "Wed, 11 Jan 1984 05:00:00 GMT"

AcceptFilter http none
AcceptFilter https none
EnableSendfile Off
EnableMMAP off
Timeout 120
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
Posts: 0
Joined: Thu Aug 25, 2011 10:07 pm

Return to Playing on Mobile Devices

Who is online

Users browsing this forum: No registered users and 2 guests