Playing multiple ums activex in the same windows form

Issues related to our ActiveX control and Cross-Browser plugin hosted in Web pages

Playing multiple ums activex in the same windows form

Postby Guillermo.A.D » Fri Dec 30, 2016 4:31 pm

In our application we reproduce up to 16 streams of different sources in the same windows form.
When we reproduce more than one tile in the same windows form we detect a strange issue were frames corresponding to first stream do appear in the other streams.
Sometimes the stream1 is reproduced completelly in the other frames in a smaller size
Sometimes the overpossed image is completelly black and correct video is apparently being reproduced behind it.
Guillermo.A.D
 
Posts: 0
Joined: Wed May 04, 2016 4:34 am

Re: Playing multiple ums activex in the same windows form

Postby admin » Fri Dec 30, 2016 10:57 pm

It's probably something about your Windows forms application.
Use our c# player - add more ActiveX controls to it - does the issue still happen?
Also, use our 4-heads html webpage example from the SDK - does the issue happen with that webpage?
admin
Site Admin
 
Posts: 939
Joined: Fri Aug 21, 2009 10:13 am

Re: Playing multiple ums activex in the same windows form

Postby Guillermo.A.D » Wed Jan 04, 2017 5:12 am

admin wrote:
> Use our c# player - add more ActiveX controls to it - does the issue still happen?

we are testing it in a very simple winform application with 2 Unreal Players ActiveX inserted (7.0) and the next code:

<code>
this._player.UseMediaServer(Form1.UmsServerIp + ":" + Form1.UmsServerPort);
this._player.UseLiveAlias(Form1.UmsCameraAlias1);
this._player.Play();
this._player.DisplayPlaybackStatus(true);
this._player.EnableContextMenu(true);

this._player2.UseMediaServer(Form1.UmsServerIp + ":" + Form1.UmsServerPort);
this._player2.UseLiveAlias(Form1.UmsCameraAlias2);
this._player2.Play();
this._player2.DisplayPlaybackStatus(true);
this._player2.EnableContextMenu(true);
</code>

The error appear in some machines.
Alias used are mediaroot videos instead of real cameras.
ActiveX version is 7.0


admin wrote:
> Also, use our 4-heads html webpage example from the SDK - does the issue happen with
> that webpage?

We have tried the 4-heads example in 2 different machines. The one of the server and my machine.


>"Error: Websocket connection is closed or could not be established"

just after "Buffering..." message
So we are not able to reproduce videos using html examples.

I even tried to using Windows Media Player directly by "File->Open Url"
with the following url:

mms://UmsServer:5119/Dti1

And the result is:

"Error: Windows Media Player cannot play the file. The Player might not support the file type or a required codec might not be installed on your computer"

I can reproduce the same alias by using the Unreal player so I guess the codecs are there... what else we can do?
Guillermo.A.D
 
Posts: 0
Joined: Wed May 04, 2016 4:34 am

Re: Playing multiple ums activex in the same windows form

Postby admin » Wed Jan 04, 2017 9:13 am

Use OUR c# player - add more ActiveX controls to it - does the issue still happen?
Also, use our 4-heads html webpage that hosts OUR ActiveX control example from the SDK (not html5 webpages) - does the issue happen with that webpage?
admin
Site Admin
 
Posts: 939
Joined: Fri Aug 21, 2009 10:13 am

Re: Playing multiple ums activex in the same windows form

Postby Guillermo.A.D » Wed Jan 04, 2017 11:03 am

Sorry I did the test with the HTML5 example:

Results with the C# player example. with 4 simultaneous activex. The issue is reproducible.

Results with your webpage hosting 4 ActiveX control. The issue is NOT reproducible. It works pretty good in the web page.
Guillermo.A.D
 
Posts: 0
Joined: Wed May 04, 2016 4:34 am

Re: Playing multiple ums activex in the same windows form

Postby admin » Wed Jan 04, 2017 12:09 pm

Results with your webpage hosting 4 ActiveX control. The issue is NOT reproducible. It works pretty good in the web page.


Just to make sure - is this using IE browser?
admin
Site Admin
 
Posts: 939
Joined: Fri Aug 21, 2009 10:13 am

Re: Playing multiple ums activex in the same windows form

Postby Guillermo.A.D » Wed Jan 04, 2017 6:03 pm

I was using Firefox
Guillermo.A.D
 
Posts: 0
Joined: Wed May 04, 2016 4:34 am

Re: Playing multiple ums activex in the same windows form

Postby admin » Wed Jan 04, 2017 7:31 pm

can you try IE please
admin
Site Admin
 
Posts: 939
Joined: Fri Aug 21, 2009 10:13 am

Re: Playing multiple ums activex in the same windows form

Postby Guillermo.A.D » Mon Jan 09, 2017 12:23 pm

Results with Internet explorer.

On my windows 7 corporate machine. Video is not reproduced, and web page displays 4 gray squares in a gray background. (my computer is very restrictive in terms of corporate security so this could be expected)

Same result on other windows 7 (virtual machine, not corporate one)

Same result on a virtual machine Server 2012. (the one hosting the ums server)
Guillermo.A.D
 
Posts: 0
Joined: Wed May 04, 2016 4:34 am

Re: Playing multiple ums activex in the same windows form

Postby admin » Mon Jan 09, 2017 2:47 pm

You need to allow signed ActiveX controls in IE security
admin
Site Admin
 
Posts: 939
Joined: Fri Aug 21, 2009 10:13 am

Next

Return to Unreal ActiveX control and Cross-Browser plugin

Who is online

Users browsing this forum: No registered users and 1 guest

cron