WMP Error msg: Invalid media subtype entered

All the issues related to streaming of recorded media.

WMP Error msg: Invalid media subtype entered

Postby gulaz » Tue Jan 26, 2010 2:59 pm

Hello,

first of all, i´d like to thank for this great product, even if I haven´t managed to run it as I desire yet;)

My situation is as follows.
I have a static IP adress 78.110.213.6. I use alias gulaz.no-ip.org for this IP. This IP adress is assigned to my first microwave router. This router has DHCP service and assign local IP adress to the second home wifi router, which also use DHCP to distribute IP adresses to home network computers.
Currently I set a server with local IP and forwarded some ports to it on both routers. This computer hosts Win 2003 with IIS, Cerberus FTP server, VNC, Remote desktop and Unreal media server services.
All of the above mentioned services run without any flaws from outer aswell as innner network, except Unreal server.
And now we come to my problem.

I tried different methods of publishing my streams.
I created the web page with links: http://gulaz.no-ip.org:8023/10._serie_full.html
I tried the WMP playlist http://gulaz.no-ip.org:8023/16._serie_full.wpl
I tried direct link mms://78.110.213.6:5119/1\!Serialz\1.-18._Simpsons_full\10._serie_full/10x01.Skolni.vecirek.avi

but when I try to play these (VLC or WMP) FROM OUTTER NETWORK the WMP shows the message "Invalid media subtype entered" (I am not sure about the translation, I have czech windows, but you can try yourselves:)
When I play these FROM INNER NETWORK the files are streamed without any problem!

It is definitelly not a matter of bad port forwarding,I doublechecked this thousand times.
I appreciate any help!

PS: how can I play UMS links in Windows?
gulaz
 
Posts: 0
Joined: Tue Jan 26, 2010 2:24 pm

Re: WMP Error msg: Invalid media subtype entered

Postby admin » Wed Jan 27, 2010 11:37 am

To play UMS links, you need our Streaming Media Player.

I can play files from http://gulaz.no-ip.org:8023/10._serie_full.html with no problem!
Both ums and mms links.

Looks like you have resolved your port forwarding problem.
admin
Site Admin
 
Posts: 1040
Joined: Fri Aug 21, 2009 10:13 am

Re: WMP Error msg: Invalid media subtype entered

Postby tommybcool » Wed Jan 27, 2010 1:41 pm

I get the same error when I click on the MMS link. WMP opens and flashes that error invalid media suptype. WMP9
tommybcool
 
Posts: 0
Joined: Wed Aug 26, 2009 12:00 pm

Re: WMP Error msg: Invalid media subtype entered

Postby tommybcool » Wed Jan 27, 2010 1:52 pm

UMS works fine. Are you sure you don't have some back slashes where some forward slashes should be on your MMS?
tommybcool
 
Posts: 0
Joined: Wed Aug 26, 2009 12:00 pm

Re: WMP Error msg: Invalid media subtype entered

Postby gulaz » Wed Jan 27, 2010 2:01 pm

2 admin: Thanks for the hint about UMS! I should have figures that out;)
I am afraid there was no port forwarding problem. As you can see from tommybcool reply, he is also not able to play these files.
On my laptop and friends computer, from where I tried to play my MMS streams I have CCCP codecpack installed and I can play the very same files (simpsons) on both of these computers locally (from USB harddrive) without any problems.
I will try to play these in your player and let you know.

2 tommybcool: thanks for test and reply!
I will test UMS tommorow. The links are automatically generated via the option in Unreal media server. I am quite sure I tried swap backslashes to slashes in direct links, but I will give it some more tries.
gulaz
 
Posts: 0
Joined: Tue Jan 26, 2010 2:24 pm

Re: WMP Error msg: Invalid media subtype entered

Postby gulaz » Wed Feb 03, 2010 4:57 am

So I tested UMS with your player and works fine.
Also over HTTP and MMS I am able to play all my files.
So I guess that´s it for now:) I am now testing the authorizations, but this seems to be working as desired.

Just one question, do you plan to implement playlist and make a portable version of your player? I bet I would not be the only one who appreciate it;)
gulaz
 
Posts: 0
Joined: Tue Jan 26, 2010 2:24 pm

Re: WMP Error msg: Invalid media subtype entered

Postby tommybcool » Wed Feb 10, 2010 11:42 am

What did you do to fix the WMP error? I got the same thing. What is the solution?
tommybcool
 
Posts: 0
Joined: Wed Aug 26, 2009 12:00 pm


Return to Streaming Files

Who is online

Users browsing this forum: No registered users and 1 guest

cron